|
9 j6 R6 @) U; A/ w+ d& y- s1 M) R( f
近日小编发现,很多站长,在使用zblogphp版本的博客的时候,经常会遇到一个问题:
) ?4 a3 v4 j4 E) P! w5 z# _ .很多站长主域名是个zblogPHP博客,而目录同样放一个zblogPHP的博客,IIS环境是7.0以上,主域名下博客设置伪静态,生成web.config后,可以成功访问URL但同样按照博客提示,在二级目录,比如/hua/下面,在生成web.config的时候,二级目录页面的伪静态就会出现404错误。
- T5 e; E4 @- x/ \ 这个问题该如何解决呢?如图:二级目录下,后台伪静态设置! ( _* N) Y$ I2 i/ l5 @& {( q
.如果你按照官方提示,把web.config生成在二级目录,你在访问URL的时候,经常出现404是什么原因造成这个问题呢?那是因为,我们根目录已经生成一个zblogPHP博客,并且也实施了伪静态,且生成了web.config。 $ J; m* O9 f3 s2 a
在IIS7.0以上版本中我们会看到相对应的规则:如下图: 4 Y4 E+ }* R% [0 l1 ?5 l5 X
.这是根目录的URL重写!注意红框路径!如果,按照后台提示在二级目录生成的,同样如上图url规则是一样的,但在红框路径这个位置,却忽略了二级目录,比如/hua/这个目录!如何修改呢?我们只需要,选择每条规则,然后点击编辑,在重写URL下面的位置添加/hua/这个二级目录,然后生成如下图:
( {3 B' Q( y8 X; n, _9 B' G .这样,二级目录/hua/下面的zblogPHP博客的伪静态,就会完全生效了! 3 o3 `" t% p5 U2 G8 I2 F+ K- J
; W, N3 @, {& s- ^
* i) S7 i; {" G9 v6 _- a) l c: m
! E1 D! Y, R5 f1 S C3 S8 r8 z
% E) M: Q$ x( s C6 {, v$ O |